Problema con Sony HB-F1XDJ

Avatar de Usuario
Nodoyuna
Mensajes: 339
Registrado: 04 Mar 2011 11:37
Ubicación: Almería
Agradecido : 124 veces
Agradecimiento recibido: 19 veces

Problema con Sony HB-F1XDJ

Mensajepor Nodoyuna » 21 Jun 2015 21:19

Buenas

Recientemente compré un MSX2+, un Sony HB-F1XDJ. También me he agenciado el Megaflash ROM SCC+
No había podido probarlo antes, ya que es mi primer MSX y no tenía software para darle de comer.
Así que he grabado dos o tres roms en la microSD y enciendo el ordenador
Las primeras pantallas se ven perfectas, pero al activarse el cartucho, me salen las letras como partidas:

Imagen

Me salgo del cartucho, y de nuevo todo se ve correctamente
Medio a ciegas, cargo los juegos que tenía grabados, y mientras algunos se ven perfectamente (por ejemplo el Metal Gear), otros como el Aleste, presentan corrupción en los gráficos:

Imagen

Me he puesto en contacto con Manuel Pazos (al que creo le he fastidiado el domingo) y hemos hecho unas pruebas y tests para ver si dábamos con el fallo

Aparentemente, algún chip de video anda escacharrao. No tengo ni repajolera idea de soldar ni cacharrear a nivel hardware, pero si algún experto de por aquí quisiera echarle un vistazo y (ojalá) arreglarlo, le mando el ordenador para que lo mire y le pago lo que crea necesario por el arreglo

Saludos y gracias por anticipado

Avatar de Usuario
Yodhefim
Mensajes: 224
Registrado: 10 Ago 2014 21:21
Ubicación: SBD-BCN
Agradecido : 3 veces

Re: Problema con Sony HB-F1XDJ

Mensajepor Yodhefim » 21 Jun 2015 23:08

Enhorabuena por ambas adquisiciones. Primero de todo aclarar que creo que tenemos un parecido nivel técnico, con lo cual no te hagas muchas esperanzas con lo que te voy a decir -banghead -shock . Por mi experiencia con ciertos cartuchos a veces la solución es tan simple como limpiar los contactos de la tarjeta (pero siempre sabiendo lo que haces y con cuidado), otras la solución es tan ´curiosa´ como acertar en la posición idónea del cartucho, es decir: a veces (no me preguntes por qué), tan solo es necesario no meter el cartucho ´a tope´ sino sacarlo un poco (nunca está de más decir que: todo esto con el ordenador apagado por supuesto).
Con respecto a que ´algún chip de video pueda andar escacharrado´... pues no lo sé, no tengo ese ordenador ni esa tarjeta, pero supongo que aunque accedas a ella se sigue utilizando el vdp del MSX y si dices que se ve mal sólo cuando te metes en la Megaflash no creo que sea problema del chip gráfico. Sí que es posible que sea problema de un chip, pero yo apostaría más por uno de memoria.
Espero que lo puedas arreglar lo más pronto posible (y que alguien te pueda dar mejores consejos que los míos), para poder disfrutar del equipo.

Avatar de Usuario
ron
Mensajes: 18472
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 1647 veces
Agradecimiento recibido: 1369 veces

Re: Problema con Sony HB-F1XDJ

Mensajepor ron » 22 Jun 2015 19:12

Bueno, es un MSX2+, empezaría por ir haciéndome con un Yamaha V9958 Video Display Processor, por si aca. Lo del video es bastante evidente. Igual tienes un problema de voltajes en el VDP o en algo alrededor implicado en la circuitería de video.

¿ Qué cable de video estás usando, uno RGB a SCART ?

Avatar de Usuario
Nodoyuna
Mensajes: 339
Registrado: 04 Mar 2011 11:37
Ubicación: Almería
Agradecido : 124 veces
Agradecimiento recibido: 19 veces

Re: Problema con Sony HB-F1XDJ

Mensajepor Nodoyuna » 22 Jun 2015 19:17

Si, es un cable RGB de Retrocables

Si uso un cabe A/V normal, le pasa lo mismo

Avatar de Usuario
Taburoto
Mensajes: 1293
Registrado: 15 Mar 2011 00:40
Agradecido : 17 veces
Agradecimiento recibido: 89 veces

Re: Problema con Sony HB-F1XDJ

Mensajepor Taburoto » 22 Jun 2015 20:09

si usas el ordenador "A pelo" sin megaflash ni nada y cargas soft desde disquette? tambien falla?

se bien los caracteres es Screen 0 y Screen 1?

si haces un programa que use el modo grafico del MSX2 podemos ver que hace:

10 screen 5:color 15,4,6
20 circle (125,95),80
30 goto 30

puedes cambiar el screen 5 por 2,3,4,5,6,7,8,11,12

Avatar de Usuario
Taburoto
Mensajes: 1293
Registrado: 15 Mar 2011 00:40
Agradecido : 17 veces
Agradecimiento recibido: 89 veces

Re: Problema con Sony HB-F1XDJ

Mensajepor Taburoto » 22 Jun 2015 20:12

algún chip de video anda escacharrao.


Los MSX2+ solo tienen un chip de video,puede ser que lo que está mal es la VRAM,suelen 4 chips que forman dos bancos de 64Kb.


Volver a “MSX”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado