PiStorm. Hilo de experiencias, ayuda y recursos.

sistema_octal
Mensajes: 42
Registrado: 04 Dic 2020 13:56
Agradecido : 48 veces
Agradecimiento recibido: 6 veces
Contactar:

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor sistema_octal » 10 Sep 2021 18:07

Último mensaje de la página anterior:

ron escribió:
shanshe escribió:Uy… pues la PI3B y la PI3A llevan frecuencias distintas… lo mismo viene de ahí todo el problema…
Además si con dos pistorms te pasa lo mismo, descartamos la pistorm.
Yo tb tengo por aquí una PI3B, cuando pueda la pruebo y te digo como me va a mi…


Por dar algo de información. Yo tengo Pi 3A y 3B. Ambas funcionan perfectamente con la misma SD.
La única ventaja que le veo a la 3B es el conector para Ethernet, pero la 3B va a 1.3 GHz y la 3A va a 1.4. Supongo que con un adaptador USB de red se le puede hacer lo mismo a la Pi 3A.

Saludos

hola, yo igual, hice pruebas con una pi3b , y las temperaturas son mejores, e incluso el consumo en algunos aspectos, creo recordar, pero vamos qeu funcionar ,funciona , pero como en general el consumo es algo menor en casi todo de la 3A+, dejé esa. pero tener lan en vez de wifi y desconectar la wifi ayudaba bastante en la 3b, si no recuerdo mal, ese era el punto bueno, usandola sin wifi activada, un saludo

Avatar de Usuario
kikems
Mensajes: 4747
Registrado: 30 May 2013 19:23
Agradecido : 1864 veces
Agradecimiento recibido: 2485 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor kikems » 12 Sep 2021 01:23

Ya he dejado los links de la versión 0.8 en el primer post del hilo. Como ya sabéis, yo lo he dejado ahí un poco abandonado por falta de tiempo, pero Shanshe se ha hecho cargo de seguir manteniendo actualizada la distro de Retrowiki.
En este caso Estrayk, Ferran y Ron han colaborado para recauchutar lo que había , actualizarlo y meter las nuevas características de velocidad, red, etc...

Os recuerdo que una de la principales ventajas de esta distribución, frente a otras, es el conjunto de elementos que ha mezclado Estrayk para que los usuarios con solo 512kb de chip puedan preservar al máximo el espacio disponible. Bueno... que es la única distro que arranca desde frío el AmigaOS en 3-4 segundos, también es un punto a favor.

Esto es lo bonito del foro, cuando uno ya no puede seguir, otro llega, toma el relevo y de ese modo el proyecto sigue vivo esté quien esté. -thumbup

Avatar de Usuario
javier2112
Mensajes: 125
Registrado: 20 Ene 2020 08:26
Agradecido : 25 veces
Agradecimiento recibido: 23 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor javier2112 » 14 Sep 2021 19:09

Hola.

He seguido haciendo cosas para conseguir que funcione pero de momento no lo consigo.

En primer lugar, he repasado y revisado soldaduras de una de las pistorm, sin conseguir nada con ello.

Luego he puesto el 68000 y sin problemas, pero me he quedado con eso de un posible fallo en la ram, así que me he buscado un tester de memoria y esto es lo que he obtenido:
Imagen

En ese momento he pensado que había dado con la tecla. He deshabilitado la ampliación y he vuelto a pasar el test, que ahora ya da OK. Entonces he preparado la distribución Retrowiki desde 0 y otra vez igual: pantalla negra o verde en ocasiones. Incluso ahora al intentar el flasheo de la CPLD me da un error -banghead

Las pruebas con la otra pistorm dan el mismo resultado. Solo se me ocurre conseguir un test del equipo más exhaustivo y como alternativa, buscarme otra raspberry, solo por descartar.

Avatar de Usuario
mgyv
Mensajes: 20
Registrado: 10 May 2021 21:49
Ubicación: Vigo
Agradecido : 27 veces
Agradecimiento recibido: 19 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor mgyv » 14 Sep 2021 22:25

Vamos a ver si puedo despejar alguna duda...Manta a la cabeza, y ¡a desguazar mi A500! -grin
Como veo en las fotos, tienes la chip ram toda en la placa base. Yo tengo exactamente esa configuración en uno de los 2 A500 que tengo.

Imagen

La pantalla verde, en primera instancia, es fallo de memoria, como te han dicho.
Partimos de que tienes el puente en JP2 para tener configurada la memoria como chip (veo el cable conectado a la pata del oscilador).
También partimos de que tienes JP7A abierto (yo lo tengo abierto para deshabilitar el puerto interno y utilizar la ampliación en la placa madre)

Imagen

Primero vamos a comprobar la tensión en la línea de 5v. Un punto relativamente fácil de identificar es en el electrolítico cerca de la expansión:

Imagen

En este caso tenemos 4.9v, que está muy bien. En el otro A500 me está dando unos 4.6v, y funciona correctamente.
Ojo, que cuando me dio problemas de tensión baja, en este punto tenía unos 4.2v, que en mi opinión, ya sería inaceptable.
Con la Pistorm conectada me daba 4.8v (La pistorm hizo bajar 0.1v la tensión de 5v en el resto de la placa)

El programa que utilicé cuando estaba verificando la RAM, cuando le instalé los zócalos de memoria, era el Amiga Test Kit (también tenía una diagrom a mano):

Imagen

Para hacer un test de memoria, hay que darle a F1, y nos quedaría esta pantalla:

Imagen

Vemos que ha detectado el mega de chip perfectamente. Si le damos F1, hará el test automático:

Imagen

Ahora vamos a provocar un fallo en la chip...Le quito un integrado de memoria
Bueno, si tuviéramos un fallo en los primeros 512k (000000-7ffff), supongo que tendrías pantallazo verde directo, pues la chip sería inaccesible.
En el caso de que falle la parte alta de la chip (080000-0FFFFF), ya no está tan claro, pues el amiga, en el arranque y detección de memoria, al no detectar los 16 bits intactos (en este caso fallarían 4 bits de los 16), da por hecho que no tienes la ampliación:

Imagen

Al arrancar de nuevo el Test kit:

Imagen

Solo detecta 512k, aunque los jumpers estén en la posición de 1mb de chip. Y ojo, que el medio mega detectado funciona correctamente.
Sin embargo, si vamos al chequeo de memoria manual del rango 80000-FFFFF:

Imagen

La memoria está ahí, aunque le falten 4 bits, que curiosamente están en la posición que "falla en la placa"
Fijáos en la parte de bus de datos de 16 bits. Los guiones son bits de datos OK, las X son defectuosos.

Bueno, no sé si te he aclarado algo. Si quieres que haga alguna prueba más, avisa....
Adjuntos
Tensión_Placa_68000.jpg
(522.56 KiB) No descargado aún
Mi500.jpg
(458.45 KiB) No descargado aún
JP7A_Abierto.jpg
(460.64 KiB) No descargado aún
FalloProvocado.jpg
(525.66 KiB) No descargado aún
ATK_TestManualAlta.jpg
(429.72 KiB) No descargado aún
ATK_MemTestMenu.jpg
(427.71 KiB) No descargado aún
ATK_Detecta512k.jpg
(252.54 KiB) No descargado aún
ATK_Checking1mb.jpg
(414.59 KiB) No descargado aún
AmigaTestKit.jpg
(409.19 KiB) No descargado aún
-coam1 A500 [030-40, 1+5mb], CD32 [2+8mb]

Avatar de Usuario
javier2112
Mensajes: 125
Registrado: 20 Ene 2020 08:26
Agradecido : 25 veces
Agradecimiento recibido: 23 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor javier2112 » 14 Sep 2021 23:15

mgyv escribió:Vamos a ver si puedo despejar alguna duda...Manta a la cabeza, y ¡a desguazar mi A500! -grin
Como veo en las fotos, tienes la chip ram toda en la placa base. Yo tengo exactamente esa configuración en uno de los 2 A500 que tengo.
(...)

Gracias. Como dije, tras deshabilitar la ampliación, el test de memoria lo ha pasado correctamente y aun así la pistorm sigue sin funcionar. No obstante, seguro que me vendrá muy bien el Amiga Test Kit y hacer ciertas comprobaciones que has indicado.


Saludos.

zakhar
Mensajes: 8
Registrado: 07 May 2020 19:08
Agradecido : 1 vez
Agradecimiento recibido: 5 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor zakhar » 17 Sep 2021 15:23

Primero de todo, gracias a todos los que habéis contribuido con la distro de Retrowiki, un currazo, lo tengo todo montado con la 0.8 y funciona mejor de lo esperado, la verdad es que le da una nueva vida al amiga 500.

Tengo un par de dudas, en Windows soy capaz de ver la carpeta compartida de la pi pero cuando intento entrar las distintas combinaciones de usuario y contraseña, pi, root, dietpi no me funcionan, me dice acceso denegado por SSH no hay problema.

por otro lado veo videos con maravillosos escritorios a todo color a través del RTG pero yo cuando lo activo y deslizo los colores a tope sigo viendo los mismos colores por el hdmi, me falta activar algo?.

Una reflexión, todo esto de la Pistorm es maravilloso, pero me he dado cuenta de que todos estos jueguines que van sacando para amiga500 "pelao" que antes me hacía ilusion probar ahora dejan de tener un poco de sentido.. que opinaís?

Saludos.

Avatar de Usuario
shanshe
Mensajes: 75
Registrado: 17 Feb 2018 19:01
Agradecido : 3 veces
Agradecimiento recibido: 63 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor shanshe » 18 Sep 2021 11:19

zakhar escribió:Tengo un par de dudas, en Windows soy capaz de ver la carpeta compartida de la pi pero cuando intento entrar las distintas combinaciones de usuario y contraseña, pi, root, dietpi no me funcionan, me dice acceso denegado por SSH no hay problema.

Yo en mac entro tal cual, "dietpi" "dietpi" y ya está.
zakhar escribió:por otro lado veo videos con maravillosos escritorios a todo color a través del RTG pero yo cuando lo activo y deslizo los colores a tope sigo viendo los mismos colores por el hdmi, me falta activar algo?.

El fondo que tenemos puesto creo que es de 4 colores, si aumentas los colores vas a seguir viendo lo mismo, tanto en video nativo como en RTG. Prueba un nuevo fondo, con más colores y ya verás la diferencia :)

Y con respecto a la reflexión, yo saqué el 500 sólo para ver la última demo de TBL... lo tenía abandonado por sus limitaciones. Con la pistorm le estoy dando una nueva vida... de hecho ahora trasteo más con el 500 que con el 4000... Sin aceleradora... pues se hubiera quedado otra temporada en la caja...

retrolab
Mensajes: 499
Registrado: 10 May 2014 18:06
Agradecido : 5 veces
Agradecimiento recibido: 21 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor retrolab » 20 Sep 2021 21:38

Alguien ha probado de instalar la nueva versión 3.2 una vez estaba ya funcionando ok la PiStorm?

Avatar de Usuario
ron
Mensajes: 20017
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 2836 veces
Agradecimiento recibido: 2636 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor ron » 20 Sep 2021 21:44

retrolab escribió:Alguien ha probado de instalar la nueva versión 3.2 una vez estaba ya funcionando ok la PiStorm?


Si, algunos de nosotros lo hicimos, y ha ido todo bien. ¿ Has tenido algún problema ?

retrolab
Mensajes: 499
Registrado: 10 May 2014 18:06
Agradecido : 5 veces
Agradecimiento recibido: 21 veces

Re: PiStorm. Hilo de experiencias, ayuda y recursos.

Mensajepor retrolab » 21 Sep 2021 08:05

De momento no, pero me llegara una Pistorm de Polonia y querria estrenar la 3.2. Gracias


Volver a “Hardware Amiga”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado