Interface ROM Externa para ZX81....Historia de un fracaso

Avatar de Usuario
minter
Mensajes: 987
Registrado: 22 Jul 2014 18:51
Agradecido : 218 veces
Agradecimiento recibido: 151 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor minter » 10 Mar 2017 20:09

Último mensaje de la página anterior:

Creo que con ese montaje, no salen la ecuaciones.
Cualquier cero, uno, que es cero.
Todo unos, cero, que es uno.
Debería ser un único uno.
Toy con el móvil en el tren, puede que la vista me falle, pero no me cuadra.
Vale... vale... no lo había leído... las ecuaciones son para NOR no para NAND. Desde el tren no se lee un pijo. -grin

Avatar de Usuario
wilco2009
Mensajes: 1409
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 12 veces
Agradecimiento recibido: 30 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor wilco2009 » 11 Mar 2017 00:19

Sí, es que es el símbolo americano para el NOR (o eso creo). El hecho es que depende de que librería cojas en el Eagle utiliza ese símbolo o el otro al que estamos más acostumbrados.
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
eltargui
Mensajes: 191
Registrado: 06 Feb 2014 18:38
Agradecido : 17 veces
Agradecimiento recibido: 18 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor eltargui » 17 Mar 2017 20:29

He metido una sonda lógica para ver cómo se comportaba el montaje.

Imagen

A la vista de los resultados de la sonda lógica, se observa que durante el ciclo de refresco (/RSFH = 0), la señal /CE = 1, es decir la EPROM externa no está disponible, y las señales /REQ y /ROMCS se encuentran en valor 0, lo cual quiere decir que la ROM interna está activa y el Z80 puede acceder a la memoria. Del mismo modo, durante el ciclo de refresco, /RD = 0 lo cual es correcto.

Cuando no hay ciclo de refresco (/RFSH = 1), la EPROM se encuentra disponible (/CE = 0 y /ROMCS = 1) y los datos de la EPROM se encuentran disponibles (/OE = 0) cuando son requeridos (/MREQ = 0 y /RD =0). Las ecuaciones de la puerta NOR para /CE se cumplen.

La otra ecuación de la puerta NOR para /OE también se cumple, ya que /OE replica la señal de /MREQ dado que A14 = 0 en todo momento.

En resumen, el montaje hace lo que se supone que debería hacer o por lo menos yo lo interpreto así. Pero el caso es que no funciona.

-banghead que bonito¡¡¡. Dropbox ha cumplido su palabra y se ha cargado todos los enlaces públicos que tenía en todos los foros y ahora ya no salen ni fotos, ni nada. Muy mal -nj

Avatar de Usuario
gflorez
Mensajes: 465
Registrado: 12 Sep 2014 19:58
Agradecimiento recibido: 42 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor gflorez » 17 Mar 2017 21:55

Seguramente no tenga nada que ver pero.... hace poco, con un osciloscopio muy preciso, se han descubierto picos estraños en las señales del bus de expansión del Enterprise. Concretamente en /RD. Habían pasado desapercibidos en todos estos años...

Los viejos chips no lo notaban, pero al usar chips mas modernos en nuevos proyectos, sucedían errores inesperados.

Imagen

Avatar de Usuario
wilco2009
Mensajes: 1409
Registrado: 07 Ene 2013 16:48
Ubicación: Valencia
Agradecido : 12 veces
Agradecimiento recibido: 30 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor wilco2009 » 18 Mar 2017 16:21

eltargui escribió:He metido una sonda lógica para ver cómo se comportaba el montaje.

Imagen

A la vista de los resultados de la sonda lógica, se observa que durante el ciclo de refresco (/RSFH = 0), la señal /CE = 1, es decir la EPROM externa no está disponible, y las señales /REQ y /ROMCS se encuentran en valor 0, lo cual quiere decir que la ROM interna está activa y el Z80 puede acceder a la memoria. Del mismo modo, durante el ciclo de refresco, /RD = 0 lo cual es correcto.

Cuando no hay ciclo de refresco (/RFSH = 1), la EPROM se encuentra disponible (/CE = 0 y /ROMCS = 1) y los datos de la EPROM se encuentran disponibles (/OE = 0) cuando son requeridos (/MREQ = 0 y /RD =0). Las ecuaciones de la puerta NOR para /CE se cumplen.

La otra ecuación de la puerta NOR para /OE también se cumple, ya que /OE replica la señal de /MREQ dado que A14 = 0 en todo momento.

En resumen, el montaje hace lo que se supone que debería hacer o por lo menos yo lo interpreto así. Pero el caso es que no funciona.

-banghead que bonito¡¡¡. Dropbox ha cumplido su palabra y se ha cargado todos los enlaces públicos que tenía en todos los foros y ahora ya no salen ni fotos, ni nada. Muy mal -nj


Pues que putada, porque debería de funcionar. El problema es que no tengo mucho tiempo para hacer unas pruebas, pero de todas formas, si el cronograma hace lo que se supone que debería de hacer estamos estancados. :(
"Nada viaja a mayor velocidad que luz con la posible excepción de las malas noticias las cuales obedecen a sus propias leyes."

Douglas Adams. Guía de autoestopista galáctico.

Avatar de Usuario
eltargui
Mensajes: 191
Registrado: 06 Feb 2014 18:38
Agradecido : 17 veces
Agradecimiento recibido: 18 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor eltargui » 19 Mar 2017 12:42

wilco2009 escribió:Pues que putada, porque debería de funcionar. El problema es que no tengo mucho tiempo para hacer unas pruebas, pero de todas formas, si el cronograma hace lo que se supone que debería de hacer estamos estancados.


gflorez escribió:Seguramente no tenga nada que ver pero.... hace poco, con un osciloscopio muy preciso, se han descubierto picos estraños en las señales del bus de expansión del Enterprise. Concretamente en /RD. Habían pasado desapercibidos en todos estos años...


Con la pista que me ha dado gflorez, voy a probar con un 74LS02 en vez del 74ACT02 que es más rápido que el primero. Haré las mismas mediciones y tan pronto obtenga resultados lo comparto.

Avatar de Usuario
minter
Mensajes: 987
Registrado: 22 Jul 2014 18:51
Agradecido : 218 veces
Agradecimiento recibido: 151 veces

Re: Interface ROM Externa para ZX81....Historia de un fracaso

Mensajepor minter » 19 Mar 2017 14:08

el 7402 lleva condensador de desacoplo?


Volver a “Sinclair ZX80/81”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados