Color en un Apple IIe PAL

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 13:55

Último mensaje de la página anterior:

Esta mañana estuve investigando más a fondo, y me parece que he encontrado el motivo de la mala señal. El TCA650 (que por cierto es un hack total porque es un demodulador en vez de un modulador) se encarga de generar las señales transportadoras (carrier wave) de R-Y y U-Y. La cosa es que para ser una señal PAL correcta, la R-Y tiene que cambiarla de fase en cada VSYNC. Y me la miro y que no cambia de fase! Eso explicaría por qué las teles que tengo no consiguen poner nada en rojo (y la Trinitron la manda directamente a la mierda y no enseña nada de color).

Afortunadamente hay TCA650 a montones y son baratos (por eso los usó Apple, seguro) o sea que me acabo de pedir uno. A ver si con eso se arregla o andaba yo muy desencaminado.

Avatar de Usuario
ron
Mensajes: 19151
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 2155 veces
Agradecimiento recibido: 1941 veces

Re: Color en un Apple IIe PAL

Mensajepor ron » 21 Abr 2020 15:04

Pon lo que quieras amigo, por mi parte me hubiera gustado hacer fotos con el monitor bien calibrado y ajustado. En 40 y 80 columnas, es un 1084 y créeme que se ve de flipar por la patilla. Lo que pasa que la última vez que lo estuve usando le baje el color y el brillo y el contraste para que una webcam lo pudiera enfocar. Cosas del cacharreo.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 16:40

Vale. Creo que ya lo tengo. No era exactamente lo que pensaba. El TCA650 seguramente está bien, aunque el problema es lo mismo que la señal transportadora de R-Y no se invierte.

Esta es la parte que manda la señal de invertir esa onda una vez cada pantalla.
diag.png
diag.png (54.54 KiB) Visto 343 veces


Al LS74 le llega la señal en la patilla 3, y como es un flip flop que tiene de entrada el negativo de su salida, cada vez que le llegue un pulso en la patilla 3, la salida tendría que cambiar y mantenerse cambiada.

Pero... esto es lo que pasa!
clock_out.png
clock_out.png (792.99 KiB) Visto 343 veces

La salida del flip flop no se mantiene! En cuanto la patilla 3 baja, la salida baja!

Y para más recochineo, esto es lo que hay en la salida negativa del flip flop:
clock_negout.png
clock_negout.png (798.6 KiB) Visto 343 veces


La mayor parte del tiempo está a 1V. O sea que ni sube ni baja. Pero está conectada a la entrada, o sea que me da que hay por ahí un corto.

Pero bueno, que estoy casi seguro que esto se arregla con un 74xx74 y listo. La cosa es que no creo que tenga uno por ahí. ¿Sabéis si se encuentra en placas de Spectrum o Amstrad? Me molaría un montón arreglarlo esta semana y no dejar el vídeo pendiente.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 16:51

Aha! Acabo de encontrar un 74HC74 en un kit the Harlequin que todavía no había montado :-)

Avatar de Usuario
kikems
Mensajes: 4088
Registrado: 30 May 2013 19:23
Agradecido : 1421 veces
Agradecimiento recibido: 1831 veces

Re: Color en un Apple IIe PAL

Mensajepor kikems » 21 Abr 2020 17:58

Nos tienes a todos con el corazón en un puño. Jajj.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 18:06

kikems escribió:Nos tienes a todos con el corazón en un puño. Jajj.

Esas son las emociones del "directo" :-)

Pues lo acabo de cambiar, y esto es como cambia la salida del flip flop:
app1.JPG
app1.JPG (551.94 KiB) Visto 335 veces


Y esto es como cambia la pantalla:
app2.JPG
app2.JPG (567.88 KiB) Visto 335 veces


Por fin!!!!! Este costó, pero cuando los pillas y encaja todo, queda muy bien :-)

Avatar de Usuario
ron
Mensajes: 19151
Registrado: 28 Oct 2010 14:20
Ubicación: retrocrypta
Agradecido : 2155 veces
Agradecimiento recibido: 1941 veces

Re: Color en un Apple IIe PAL

Mensajepor ron » 21 Abr 2020 18:23

caguenmimanto manín ! jaajaaja ( diría minter ) ! ! !
Bravo ! plas plas plas plas !!!!

ivan
Mensajes: 22
Registrado: 30 Mar 2020 21:03
Ubicación: Las Rozas de Madrid
Agradecido : 14 veces
Agradecimiento recibido: 18 veces

Re: Color en un Apple IIe PAL

Mensajepor ivan » 21 Abr 2020 18:39

Bien \o/

Avatar de Usuario
papalapa
Mensajes: 595
Registrado: 05 Ago 2018 18:22
Agradecido : 269 veces
Agradecimiento recibido: 177 veces

Re: Color en un Apple IIe PAL

Mensajepor papalapa » 21 Abr 2020 18:46

llopis escribió:Pues lo acabo de cambiar, y esto es como cambia la salida del flip flop:
Por fin!!!!! Este costó, pero cuando los pillas y encaja todo, queda muy bien :-)


Que barbaridad, no hay retrocacharro que se te resista -woot_jump

Bueno, ahora ya no tienes excusa para hacer el video del wDrive...

jltursan
Mensajes: 3075
Registrado: 20 Sep 2011 13:59
Agradecido : 257 veces
Agradecimiento recibido: 765 veces

Re: Color en un Apple IIe PAL

Mensajepor jltursan » 21 Abr 2020 19:02

Caray, ¡buen trabajo!, vaya culebrón que parece que hay detrás del color en estos equipos...

¿Me lo parece a mí o aunque ya se distinguen claramente los colores principales (rojo, verde, azul...), la imagen carece de saturación?

Quickie
Mensajes: 44
Registrado: 01 Nov 2018 17:48
Agradecido : 6 veces
Agradecimiento recibido: 19 veces

Re: Color en un Apple IIe PAL

Mensajepor Quickie » 21 Abr 2020 20:28

¡¡Felicidades!!

Muy didáctico (como siempre) y útil -thumbup

Voy a hacer un copy/paste de tu análisis y ver que muestra el osciloscopio en mi IIe, del que tengo sospechas de que tampoco muestra bien los colores...

Por desgracia no tengo manera de ejecutar ese test (AppleIISD pcb de camino y no tengo disquetera), por lo que lo poco que he probado ha sido desde BASIC.

Aprovecho para preguntar si:

- ¿Es normal que en un IIe con tarjeta de expansión de RAM y 80 columnas muestre el mensaje de boot de Apple ][ y no Apple //e (es un IIe español con switch)?

- ¿Es normal que al hacer un POKE 49232,0 aparezca una pantalla blanca con algunos cuadrados de colores y no se pueda ver ningun carácter por pantalla?

- Cambié el 6502 por un 65C02 (del que tengo dudas de su autenticidad) con vistas de convertirlo a IIe enhanced, pero sin cambiar las roms al iniciar no suene el beeper y muestra una pantalla parecida a la que obtengo con el POKE mencionado.

Perdonad el off-topic. Si creéis que debiera plantear las dudas en otro hilo comentádmelo sin problema.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 20:54

papalapa escribió:
llopis escribió:Bueno, ahora ya no tienes excusa para hacer el video del wDrive...

Jajaja... si esto empezó porque estaba haciendo el vídeo del wDrive, pero me empecé a enredar con lo del color, y al final dejaré el wDrive para otro día porque entre esto y en enhanced kit tengo de sobra.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 21 Abr 2020 21:35

jltursan escribió:¿Me lo parece a mí o aunque ya se distinguen claramente los colores principales (rojo, verde, azul...), la imagen carece de saturación?

Creo que era la foto y que todavía no había ajustado los colores con los potenciómetros. Lo acabo de hacer y sacar una foto mejor:
app3.JPG
app3.JPG (811.02 KiB) Visto 291 veces

ivan
Mensajes: 22
Registrado: 30 Mar 2020 21:03
Ubicación: Las Rozas de Madrid
Agradecido : 14 veces
Agradecimiento recibido: 18 veces

Re: Color en un Apple IIe PAL

Mensajepor ivan » 22 Abr 2020 00:24

Quickie escribió:- ¿Es normal que en un IIe con tarjeta de expansión de RAM y 80 columnas muestre el mensaje de boot de Apple ][ y no Apple //e (es un IIe español con switch)?

- ¿Es normal que al hacer un POKE 49232,0 aparezca una pantalla blanca con algunos cuadrados de colores y no se pueda ver ningun carácter por pantalla?

- Cambié el 6502 por un 65C02 (del que tengo dudas de su autenticidad) con vistas de convertirlo a IIe enhanced, pero sin cambiar las roms al iniciar no suene el beeper y muestra una pantalla parecida a la que obtengo con el POKE mencionado.

Perdonad el off-topic. Si creéis que debiera plantear las dudas en otro hilo comentádmelo sin problema.


- Sí, es normal que te salga "Apple ][". Tienes que poner las ROMS de enhanced para que salga //e

- Tambien son normales los cuadrados de colores al hacer ese POKE. Estás cambiando a modo baja resolución sin borrar la memoria de texto que es compartida.

- Esto último ni idea. No se me ocurre qué podría ser.

Quickie
Mensajes: 44
Registrado: 01 Nov 2018 17:48
Agradecido : 6 veces
Agradecimiento recibido: 19 veces

Re: Color en un Apple IIe PAL

Mensajepor Quickie » 22 Abr 2020 01:19

Dudas resueltas. Mil gracias :)

Del tema del procesador, como intuía, se trata de a saber qué IC remarcado a 65C02P4.
Ví que un 65C02P4 original no debiera tener el pin 1 y 21 a GND y éste lo tiene, así que caso resuelto -thumbup


ivan escribió:
Quickie escribió:- ¿Es normal que en un IIe con tarjeta de expansión de RAM y 80 columnas muestre el mensaje de boot de Apple ][ y no Apple //e (es un IIe español con switch)?

- ¿Es normal que al hacer un POKE 49232,0 aparezca una pantalla blanca con algunos cuadrados de colores y no se pueda ver ningun carácter por pantalla?

- Cambié el 6502 por un 65C02 (del que tengo dudas de su autenticidad) con vistas de convertirlo a IIe enhanced, pero sin cambiar las roms al iniciar no suene el beeper y muestra una pantalla parecida a la que obtengo con el POKE mencionado.

Perdonad el off-topic. Si creéis que debiera plantear las dudas en otro hilo comentádmelo sin problema.


- Sí, es normal que te salga "Apple ][". Tienes que poner las ROMS de enhanced para que salga //e

- Tambien son normales los cuadrados de colores al hacer ese POKE. Estás cambiando a modo baja resolución sin borrar la memoria de texto que es compartida.

- Esto último ni idea. No se me ocurre qué podría ser.

Avatar de Usuario
llopis
Mensajes: 340
Registrado: 21 Ago 2018 15:27
Ubicación: Asturias
Agradecido : 148 veces
Agradecimiento recibido: 251 veces
Contactar:

Re: Color en un Apple IIe PAL

Mensajepor llopis » 24 Abr 2020 15:50

Pues aquí tenéis el vídeo con todo el proceso y resultado finales. Aunque con este hilo ya le he quitado mucha emoción :-)
https://youtu.be/NTs8a_DRPwg

Avatar de Usuario
papalapa
Mensajes: 595
Registrado: 05 Ago 2018 18:22
Agradecido : 269 veces
Agradecimiento recibido: 177 veces

Re: Color en un Apple IIe PAL

Mensajepor papalapa » 24 Abr 2020 18:31

Saber el resultado antes del enunciado es cierto que le quita emoción pero sigue siendo igualmente muy interesante.

A ver como nos apañamos ahora si tardas dos o tres semanas entre video y video, pillaremos mono... -mega_shok


Volver a “Apple ][”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 1 invitado